Pascal: Les structures de contrôle conditionnelles

Les structures de contrôle conditionnelles




  1. Définitions et utilisations
    • La structure de contrôle conditionnelle permet à un programme de modifier son traitement en fonction d’une condition.
    • Il existe 4 formes d’instructions conditionnelles:
      • Forme Simple
      • Forme alternative
      • Forme généralisée
      • Forme à choix multiple

  2. Forme Simple
    • Définition
      Une structure de contrôle conditionnelle est dite à forme simple réduite lorsque le traitement dépend d’une condition. Si la condition est évaluée à « vrai », le traitement est exécuté.

      Analyse Algorithme Pascal
      R=[Initilisations]
      Si (condition(s) 1) Alors
      Traitement1
      Sinon Si (condition(s) 2) Alors
      Traitement 2
      …………………………………
      Sinon Si (condition(s) n-1) Alors
      Traitement n-1
      Sinon
      Traitement n
      FinSi
      Initilisations
      Si (condition(s) 1) Alors
      Traitement1
      Sinon Si (condition(s) 2) Alors
      Traitement 2
      …………………………………
      Sinon Si (condition(s) n-1) Alors
      Traitement n-1
      Sinon
      Traitement n
      FinSi
      Initialisations ;
      IF (condition(s)1) then
      Trait1 ;
      Else If (condition(s)1) then
      Trait2 ;
      ………………………………….. ;
      Else If (condition(s)n-1) then
      Trait n-1 ;
      Else Trait n ;

      Activité
      Ecrire un programme pascal qui permet de saisir un entier x et d’afficher le message « racine carré existe » si x est positif 0.
      Analyse

      <strong>Résultat =</strong> Écrire (message)
      <strong>Traitement</strong> =
      message = [message <--"" ] Si x > 0 alors
      message <-- "racine carré existe"
      Finsi
      x = Donnée ("Taper un entier : ")
      Données : x
      

      Tableau de déclaration des objets

      Objet Nature / Type
      message
      x
      Chaîne de caractères
      Entier.

      Algorithme

      0) Début RACINE_CARRE
      1) Ecrire (" Taper un entier : "), lire (x)
      2) message "" Si x > 0 alors
       message  "racine carré existe"
      Finsi
      3) Écrire (message)
      4) Fin RACINE_CARRE
      

      Traduction en Pascal

      PROGRAM RACINE_CARRE;
      USES WINCRT;
      VAR
      x : INTEGER;
      Message : STRING;
      BEGIN
      WRITE ('Taper un entier : ');
      READLN (x);
      message:= '' ;
      IF x >0 THEN
      Message := 'racine carré existe' ;
      WRITELN (message);
      END.
      

  3. Forme alternative
    • Définition:
      Une structure de contrôle conditionnelle est dite à forme alternative lorsque le traitement dépend d’une condition à deux états: Si la condition est évaluée à « vrai », le premier traitement est exécuté; traitement dépend d’une condition à deux états: Si la condition est évaluée à « faux »,le second traitement est exécuté.

      Analyse Algorithme Pascal
      [Init] Si condition Alors
      Instruction 1 de TR1
      Instruction 2 de TR1
      ….
      Instruction m de TR1
      Sinon
      Instruction 1 de TR2
      Instruction 2 de TR2
      ….
      Instruction n de TR2
      FinSi
      ……. {Init}
      Si condition Alors
      Instruction 1 de TR1
      Instruction 2 de TR1
      ….
      Instruction m de TR1
      Sinon
      Instruction 1 de TR2
      Instruction 2 de TR2
      ….
      Instruction n de TR2
      FinSi
      ……. ; {Init}
      IF condition THEN
      Begin
      Instruction_1_de_TR1;
      Instruction_2_de_TR1;
      …………….;
      Instruction_m_de_TR1;
      End
      ELSE
      Begin

      Instruction_1_de_TR2;
      Instruction_2_de_TR2;
      …………….;
      Instruction_n_de_TR2;
      End;

  4. Forme généralisée
    • Définition
      Une structure de contrôle conditionnelle est dite généralisée lorsqu’elle permet de résoudre des problèmes comportant plus de deux traitements en fonction des conditions. L’exécution d’un traitement entraîne automatiquement la non exécution des autres traitements.

      Analyse Algorithme Pascal
      R=[Initilisations]
      Si (condition(s) 1) Alors
      Traitement1
      Sinon Si (condition(s) 2) Alors
      Traitement 2
      …………………………………
      Sinon Si (condition(s) n-1) Alors
      Traitement n-1
      Sinon
      Traitement n
      FinSi
      Initialisations
      Si (condition(s) 1) Alors
      Traitement1
      Sinon Si (condition(s) 2) Alors
      Traitement 2
      …………………………………
      Sinon Si (condition(s) n-1) Alors
      Traitement n-1
      Sinon
      Traitement n
      FinSi
      Initialisations ;
      IF (condition(s)1) then
      Trait1 ;
      Else If (condition(s)1) then
      Trait2 ;
      ………………………………….. ;
      Else If (condition(s)n-1) then
      Trait n-1 ;
      Else Trait n ;

  5. Forme à choix multiple
    • Définition

    • Cette structure permet une présentation plus claire d’un ensemble d’alternatives imbriquées. Un nombre important de choix est à envisager selon les valeurs prises par une variable.
    • La structure SELON évalue le “sélecteur”, passe à comparer celui-ci respectivement avec les valeurs dans les listes. En cas d’égalité avec une valeur, les actions correspondantes, qui sont devant cette valeur seront exécutées.
    • Analyse Algorithme Pascal
      R=[Initilisations]
      Selon Sélécteur Faire
      Val1 :action1
      Val2,val3 :action21
      action22 action2n
      Val4 :action3
      Valn :action n
      Sinon action R
      Fin selon
      Initialisations
      Selon Sélecteur Faire
      Val1 :action
      Val2,val3 :action21
      action22 action2n
      Val4 :action3
      Valn :action n
      Sinon action R
      Fin selon

      Initialisations ;
      Case sélécteur of
      Val1 :action1 ;
      Val2,val3 :begin
      action21 ; action22 ; action2n ; end ;
      Val4 :action3 ; Valn :action n; else action R end ;


Abonnez vous à notre chaîne YouTube gratuitement